Jump to content

Custom Search




Welcome to the Ford C-MAX Energi Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford C-MAX Energi Forum. You must register to create topics or post in our community - but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford C-MAX Energi Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more.
Click here to create an account now.
 
Guest Message by DevFuse

Get you C-MAX Energi Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

outrageous mileage with MFM


  • Please log in to reply
32 replies to this topic

#21 OFFLINE   GlennR

GlennR

    New Member

  • C-MAX Energi Member
  • Pip
  • 61 posts
  • Region:Canada Ontario
  • LocationBrampton
  • My C-MAX:2016
  • Current Vehicle:C-Max Energi 2016

Posted 28 January 2018 - 05:07 AM

The same issue has started for me, I'm showing anywhere between 0.1 mpg to 2,400 mpg. This software has been buggy from the start but, wow, it's totally useless now.

 

Update:

Now it's almost nine thousand miles per gallon showing. I emailed mobile support to see if they could provide an update on what's going on but I've only received an automated acknowledgment of my query so far. 


Edited by GlennR, 29 January 2018 - 09:05 AM.








Lose this advertisement by becoming a member. Click here to create a free account.

#22 OFFLINE   coair73x

coair73x

    New Member

  • C-MAX Energi Member
  • Pip
  • 22 posts
  • Region:U.S. Northeast
  • LocationWashington DC
  • My C-MAX:2016
  • Current Vehicle:2016 C-MAX Energi SEL 303a Glass Roof 2016 C-Max Energi SEL 302a Black

Posted 29 January 2018 - 08:08 PM

Well I can report that both of my 16 Cmax Energi`s both report 5000mpg!  Just had modem replaced on my black pre owned one and after ride home from dealer 5000mpg. So I would say its on Fords side. I will call them back and see what kind of bs they will give me.



#23 OFFLINE   coair73x

coair73x

    New Member

  • C-MAX Energi Member
  • Pip
  • 22 posts
  • Region:U.S. Northeast
  • LocationWashington DC
  • My C-MAX:2016
  • Current Vehicle:2016 C-MAX Energi SEL 303a Glass Roof 2016 C-Max Energi SEL 302a Black

Posted 29 January 2018 - 08:16 PM

I read on another forum that mfm is working on a fix.



#24 OFFLINE   GlennR

GlennR

    New Member

  • C-MAX Energi Member
  • Pip
  • 61 posts
  • Region:Canada Ontario
  • LocationBrampton
  • My C-MAX:2016
  • Current Vehicle:C-Max Energi 2016

Posted 02 February 2018 - 08:04 AM

Has anybody had a correction of this issue yet?



#25 OFFLINE   rbort

rbort

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 3,904 posts
  • Region:U.S. Northeast
  • LocationFranklin, MA
  • My C-MAX:2017
  • Current Vehicle:Cmax Energi Titanium with Moonroof

Posted 02 February 2018 - 09:10 AM

They called me last night, said they were working on the MPG problem.  I forgot to tell them the charge times are all the same too, bummer...hopefully that will get fixed at the same time.

 

Weird thing is that they asked me to change my MFM password to something they want so they can log into my account and look.  But after we spoke a bit about the issue, they said if its the MPG thing then they know about it and don't need to log into my account.

 

-=>Raja.



#26 OFFLINE   GlennR

GlennR

    New Member

  • C-MAX Energi Member
  • Pip
  • 61 posts
  • Region:Canada Ontario
  • LocationBrampton
  • My C-MAX:2016
  • Current Vehicle:C-Max Energi 2016

Posted 13 February 2018 - 04:51 PM

 I wonder if they'll ever get it right. I don't understand how this big an error can be unnoticed when tested or this hard to solve. They don't notify any customer about issues or when they might fix it. I don't know that I'll get another Ford after this one. 


Edited by GlennR, 13 February 2018 - 05:12 PM.


#27 OFFLINE   rbort

rbort

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 3,904 posts
  • Region:U.S. Northeast
  • LocationFranklin, MA
  • My C-MAX:2017
  • Current Vehicle:Cmax Energi Titanium with Moonroof

Posted 13 February 2018 - 05:21 PM

Yes its still broken, that doesn't make sense why they even changed something to break it.

 

But only for the new cars, 2013 still works OK go figure...

 

-=>Raja.

 



#28 OFFLINE   coair73x

coair73x

    New Member

  • C-MAX Energi Member
  • Pip
  • 22 posts
  • Region:U.S. Northeast
  • LocationWashington DC
  • My C-MAX:2016
  • Current Vehicle:2016 C-MAX Energi SEL 303a Glass Roof 2016 C-Max Energi SEL 302a Black

Posted 15 February 2018 - 03:42 PM

I imagine since very few are complaining they are taking their time. I am curious if it is doing the same thing on 15-18 Fusion Energi's

#29 OFFLINE   GlennR

GlennR

    New Member

  • C-MAX Energi Member
  • Pip
  • 61 posts
  • Region:Canada Ontario
  • LocationBrampton
  • My C-MAX:2016
  • Current Vehicle:C-Max Energi 2016

Posted Yesterday, 09:09 AM

Any update from anyone? I've heard nothing more.



#30 OFFLINE   cr08

cr08

    New Member

  • C-MAX Energi Member
  • Pip
  • 152 posts
  • Region:U.S. Great Lakes
  • LocationColumbus, Ohio
  • My C-MAX:2013
  • Current Vehicle:2013 Ice Storm C-Max Energi

Posted Yesterday, 09:12 AM

I just wonder what the exact cause is. I have yet to see this on my 2013. In fact MFM has been absolutely flawless for me from day one (roughly mid March 2017) even through all the Android app updates. I've only ever seen the time offset issue which is a non-concern for me.



#31 OFFLINE   Tom_NC_1

Tom_NC_1

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 1,041 posts
  • Region:U.S. Southern Atlantic
  • LocationNC
  • My C-MAX:Decline
  • Current Vehicle:2013 C-Max Energi 302a

Posted Yesterday, 04:28 PM

I just wonder what the exact cause is. I have yet to see this on my 2013. In fact MFM has been absolutely flawless for me from day one (roughly mid March 2017) even through all the Android app updates. I've only ever seen the time offset issue which is a non-concern for me.

 

I have never had problems in almost almost 5 years until Feb 8, 2018. All communication between the C-Max and MFM has stopped. No text messages and no driving updates at all. Tried on both my computer and my iPhone and both fail communicating to the car. No indication in the car of any problems either.

 

Tom



#32 OFFLINE   rbort

rbort

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 3,904 posts
  • Region:U.S. Northeast
  • LocationFranklin, MA
  • My C-MAX:2017
  • Current Vehicle:Cmax Energi Titanium with Moonroof

Posted Yesterday, 05:54 PM

Its still not fixed for the 2017 models, but for 2013 and my buddy Ansy's it still seems to be working.

 

I haven't heard anything back from Ford, maybe you guys wants to contact them again?

 

-=>Raja.



#33 OFFLINE   Tom_NC_1

Tom_NC_1

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 1,041 posts
  • Region:U.S. Southern Atlantic
  • LocationNC
  • My C-MAX:Decline
  • Current Vehicle:2013 C-Max Energi 302a

Posted Today, 06:03 AM

Its still not fixed for the 2017 models, but for 2013 and my buddy Ansy's it still seems to be working.

 

I haven't heard anything back from Ford, maybe you guys wants to contact them again?

 

-=>Raja.

 

I sent a support request to MFM and they responded with a request for specific information. Just waiting to see if they come up with feedback for me.

 

Tom










0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·