Jump to content

Custom Search




Welcome to the Ford C-MAX Energi Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford C-MAX Energi Forum. You must register to create topics or post in our community - but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford C-MAX Energi Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more.
Click here to create an account now.
 
Guest Message by DevFuse

Get you C-MAX Energi Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

2013 horn and front wipers stopped working


  • Please log in to reply
2 replies to this topic

#1 OFFLINE   EVILTWIN67

EVILTWIN67

    New Member

  • C-MAX Energi Member
  • Pip
  • 1 posts
  • Region:U.S. Southern Atlantic
  • LocationCentral FL
  • My C-MAX:2013
  • Current Vehicle:2013 C Max Energi SEL

Posted 16 November 2017 - 04:49 PM

I noticed that the horn didn't beep when locking the doors so I tried pushing on the horn while the engine was on and there was no horn sound. There was dew on the windshield the next morning so I turned on the front wipers but they didn't turn on at any speed setting. The rear wiper works and the front sprayer works but not the front wipers. I checked and even replaced the horn and windshield fuses and even the microrelays under the hood and still no luck.

Has anyone else had these problems and if so how were these fixed?

Thanks in advance







Lose this advertisement by becoming a member. Click here to create a free account.

#2 OFFLINE   Perry Knopp

Perry Knopp

    New Member

  • C-MAX Energi Facebook
  • Pip
  • 153 posts
  • Region:Decline
  • LocationWV
  • My C-MAX:2013
  • Current Vehicle:FOrd

Posted 16 November 2017 - 06:05 PM

 I've never had this problem but based upon other problems the first thing I would do is find the fuses for these. Check them. Replace if bad, if not put them back and try again.


Edited by Perry Knopp, 16 November 2017 - 06:06 PM.


#3 OFFLINE   yeedk

yeedk

    New Member

  • C-MAX Energi Member
  • Pip
  • 23 posts
  • Region:Canada Ontario
  • LocationRichmond Hill
  • My C-MAX:2014
  • Current Vehicle:Ford C-Max Energi

Posted 16 November 2017 - 06:24 PM

For the horn the clockspring might be going.  Any clicking when you turn your wheel.  You might also want to check the wiring around the steering column.


Edited by yeedk, 16 November 2017 - 06:44 PM.









0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·