Jump to content

Custom Search




Welcome to the Ford C-MAX Energi Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford C-MAX Energi Forum. You must register to create topics or post in our community - but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford C-MAX Energi Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more.
Click here to create an account now.
 
Guest Message by DevFuse

Get you C-MAX Energi Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

Changing wiper blades


  • Please log in to reply
14 replies to this topic

#1 OFFLINE   pippin65

pippin65

    New Member

  • C-MAX Energi Member
  • Pip
  • 53 posts
  • Region:U.S. Southern Atlantic
  • Locationfla
  • My C-MAX:None
  • Current Vehicle:subaru ob

Posted 19 April 2016 - 12:18 PM

How do I get wipers into service mode? I started the car, turned off the ignition and held the wiper stalk toward me for a while. Nothing.







Lose this advertisement by becoming a member. Click here to create a free account.

#2 OFFLINE   pippin65

pippin65

    New Member

  • C-MAX Energi Member
  • Pip
  • 53 posts
  • Region:U.S. Southern Atlantic
  • Locationfla
  • My C-MAX:None
  • Current Vehicle:subaru ob

Posted 19 April 2016 - 12:22 PM

Got it. The manual says towards you but it's really down... Come on.
By the way, went with bosch icons

Edited by pippin65, 19 April 2016 - 12:23 PM.


#3 OFFLINE   rbort

rbort

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 3,805 posts
  • Region:U.S. Northeast
  • LocationFranklin, MA
  • My C-MAX:2017
  • Current Vehicle:Cmax Energi Titanium with Moonroof

Posted 19 April 2016 - 12:33 PM

Mine are still original.  I put them in service mode the other day while I was washing the car to get the window cleaned under them while the hood is open.

 

-=>Raja.



#4 OFFLINE   Fred Green

Fred Green

    New Member

  • C-MAX Energi Facebook
  • Pip
  • 5 posts

Posted 09 January 2017 - 04:50 PM

Pippin65 (or anyone else), have you found a decent set of replacement blades (like Bosch Icon, which number/model?) that work on the CMax?  They seem to have a proprietary connector so might be nice to collect models that are known-working.  Happy to order online rather than track them down in a physical store.



#5 OFFLINE   tr7driver

tr7driver

    New Member

  • C-MAX Energi Member
  • Pip
  • 230 posts
  • Region:Decline
  • Locationcentral
  • My C-MAX:Decline
  • Current Vehicle:C-Max energi, Fusion Ti Hy, Mustang GT, Triumph TR7

Posted 10 January 2017 - 01:17 PM

Pippin65 (or anyone else), have you found a decent set of replacement blades (like Bosch Icon, which number/model?) that work on the CMax?  They seem to have a proprietary connector so might be nice to collect models that are known-working.  Happy to order online rather than track them down in a physical store.

I ordered about 4 sets from Rock Auto.  They were dirt cheap so I ordered a bunch of them, along with several cabin air and engine air filters to make it worth shipping.  Everything fit and works as expected. 



#6 OFFLINE   jzchen

jzchen

    New Member

  • C-MAX Energi Platinum Member
  • 407 posts
  • Region:U.S. Pacific Coast
  • LocationArcadia, CA
  • My C-MAX:2013
  • Current Vehicle:2013 C-MAX Energi

Posted 26 May 2017 - 04:21 AM

I got these a while back.  I rotated one of the blade's attachment around for the aero blade to face the right direction, metal pin slides out to do this.

 

http://www.ebay.com/itm/111993871989

 

Pretty happy with their performance.



#7 OFFLINE   RubyMax

RubyMax

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 658 posts
  • Region:U.S. Great Lakes
  • LocationNortheast Ohio
  • My C-MAX:2013
  • Current Vehicle:C-Max Energi, 302A, Pano; Focus Electric

Posted 26 May 2017 - 05:04 AM

I got these a while back.  I rotated one of the blade's attachment around for the aero blade to face the right direction, metal pin slides out to do this.

 

http://www.ebay.com/itm/111993871989

 

Pretty happy with their performance.

How long was the shipping time from China?



#8 OFFLINE   James2

James2

    New Member

  • C-MAX Energi Member
  • Pip
  • 64 posts
  • Region:Decline
  • Locationmacon ga
  • My C-MAX:2013
  • Current Vehicle:2013 C-Max energi

Posted 26 May 2017 - 02:12 PM

i recently replaced mine with rain x latitudes. (28 in on drivers, 26 in on passengers.)They work great and the fit great with the supplied adapter. read the instructions. I could not figure out service mode, so I just popped the hood, was able to replace them easily with the hood up.

 

the rain x are very good wipers, very happy with them. 



#9 OFFLINE   rbort

rbort

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 3,805 posts
  • Region:U.S. Northeast
  • LocationFranklin, MA
  • My C-MAX:2017
  • Current Vehicle:Cmax Energi Titanium with Moonroof

Posted 26 May 2017 - 02:44 PM

Just looking at my post back in 2016, my wiper blades are still the same, the original ones now almost 4 years old.  They work well still also, so no reason to replace just yet even though I have a spare set.

 

-=>Raja.



#10 OFFLINE   sporkinum

sporkinum

    New Member

  • C-MAX Energi Member
  • Pip
  • 125 posts
  • Region:U.S. Mississippi Valley
  • LocationIllinois
  • My C-MAX:2014
  • Current Vehicle:C-Max Energi

Posted 26 May 2017 - 06:13 PM

I tried to do service mode, engine on, then off then pull wiper stalk back for 3 seconds. never could get it to work.


Edited by sporkinum, 26 May 2017 - 06:32 PM.


#11 OFFLINE   rbort

rbort

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 3,805 posts
  • Region:U.S. Northeast
  • LocationFranklin, MA
  • My C-MAX:2017
  • Current Vehicle:Cmax Energi Titanium with Moonroof

Posted 27 May 2017 - 01:56 AM

Should work, I've done/tried the service mode before when I read about it here.

 

-=>Raja.



#12 OFFLINE   Tom_NC_1

Tom_NC_1

    Energi Member

  • C-MAX Energi Member
  • PipPip
  • 1,032 posts
  • Region:U.S. Southern Atlantic
  • LocationNC
  • My C-MAX:Decline
  • Current Vehicle:2013 C-Max Energi 302a

Posted 27 May 2017 - 05:33 AM

I tried to do service mode, engine on, then off then pull wiper stalk back for 3 seconds. never could get it to work.

 

Within a about 3 seconds after shutting the car off pull the wiper stalk all the way down. This works every time for me to get the wipers into maintenance mode..

 

Tom



#13 OFFLINE   MaxLB

MaxLB

    New Member

  • C-MAX Energi Member
  • Pip
  • 79 posts
  • Region:U.S. Pacific Coast
  • LocationSoCal
  • My C-MAX:2016
  • Current Vehicle:2016 C-Max NRG

Posted 27 May 2017 - 08:54 AM

The picture in my owner's manual clearly shows pushing the stalk down, not pulling towards you.  Maybe they corrected this from earlier manuals?  It works for me no problem.



#14 OFFLINE   jzchen

jzchen

    New Member

  • C-MAX Energi Platinum Member
  • 407 posts
  • Region:U.S. Pacific Coast
  • LocationArcadia, CA
  • My C-MAX:2013
  • Current Vehicle:2013 C-MAX Energi

Posted 28 May 2017 - 12:55 AM

How long was the shipping time from China?

 

 

It was actually pretty quick, surprisingly, from HK if I remember correctly.  I can't remember how long it took, but, no bad memory of "when will they arrive", more of, "that was quick".  And they come in a real hard protective cylinder.  Not branded though, if that's important to you.  Ultra quick response from the seller when I noted the one side aero blade was facing the wrong way if I mounted it as is.  Then as I was trying to detach the aero lip part and reattach it facing the other direction, the center pin fell out.  I then rotated the attachment clip, put back in the pin, and all was hunky dory.  (I didn't want to trouble the seller.  They have excellent reputation, responded to the concern very rapidly, and got them to me real quick in the first place.)  Good service so I wanted to contribute to the issue as best I could.  Next time I'll remember to remove and rotate the pin around....

 

EDIT-  SO I was able to look back at my eBay and PayPal transaction details.  I ordered and paid on March 23, a Thursday.  I received them April 1.

 

Saturday, Apr 1, 2017 3:26 PM ARCADIA , CA Delivered, Left with Individual

Saturday, Apr 1, 2017 11:37 AM ARCADIA , CA Out for Delivery

Saturday, Apr 1, 2017 11:27 AM ARCADIA , CA Sorting Complete

Saturday, Apr 1, 2017 9:16 AM ARCADIA , CA Arrived at Unit

Friday, Mar 31, 2017 10:40 PM SAN BERNARDINO , CA Departed USPS Facility

Friday, Mar 31, 2017 8:38 PM SAN BERNARDINO , CA Arrived at USPS Facility

Wednesday, Mar 29, 2017 6:48 AM ISC LOS ANGELES CA (USPS) Processed Through Facility

Tuesday, Mar 28, 2017 12:09 PM HONG KONG AIR MAIL CENTRE Processed Through Facility  

                                                     N/A Origin Post is Preparing Shipment

Monday, Mar 27, 2017 11:14 AM N/A  Acceptance


Edited by jzchen, 28 May 2017 - 01:10 AM.

  • RubyMax likes this

#15 OFFLINE   jzchen

jzchen

    New Member

  • C-MAX Energi Platinum Member
  • 407 posts
  • Region:U.S. Pacific Coast
  • LocationArcadia, CA
  • My C-MAX:2013
  • Current Vehicle:2013 C-MAX Energi

Posted 28 May 2017 - 12:58 AM

The picture in my owner's manual clearly shows pushing the stalk down, not pulling towards you.  Maybe they corrected this from earlier manuals?  It works for me no problem.

 

Glad they seemed to have made it clearer.  I couldn't really tell from the arrow what to do.  I tried pulling towards me/towards the rear, and nothing.  Second try was to push downwards.  This is the correct direction.










0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·