Jump to content

Custom Search




Welcome to the Ford C-MAX Energi Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford C-MAX Energi Forum. You must register to create topics or post in our community - but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford C-MAX Energi Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more.
Click here to create an account now.
 
Guest Message by DevFuse

Get you C-MAX Energi Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

rack and pinion

rack and pinion

  • Please log in to reply
3 replies to this topic

#1 OFFLINE   rmcalondon

rmcalondon

    New Member

  • C-MAX Energi Member
  • Pip
  • 22 posts
  • Region:U.S. Southern Atlantic
  • LocationJupirer Farms
  • Current Vehicle:2013 c-max energi

Posted 20 February 2015 - 09:12 PM

My rack and pinion went out after 30k miles. Any body else have this problem? 2013 energi 14 months old.







Lose this advertisement by becoming a member. Click here to create a free account.

#2 OFFLINE   drdiesel1

drdiesel1

    Energi Member

  • C-MAX Energi Platinum Member
  • 1,645 posts
  • Region:U.S. Pacific Coast
  • LocationMonterey CA
  • My C-MAX:Decline
  • Current Vehicle:2014 Ford C-Max Energi

Posted 20 February 2015 - 11:40 PM

None that I know of.



#3 OFFLINE   fotomoto

fotomoto

    Energi Member

  • Moderator
  • 1,184 posts
  • Region:U.S. Southern Plains
  • LocationSouth Texas
  • Current Vehicle:CMAX

Posted 21 February 2015 - 05:56 AM

The volt, including my former 2012, have a sticking on center issue that was unsettling to say the least.  IIRC, it has been addressed with a recall and/or TSB but yours is the first report I've seen on a CMax.  Keep us updated.



#4 OFFLINE   dlfretz

dlfretz

    New Member

  • C-MAX Energi Member
  • Pip
  • 2 posts
  • Region:U.S. Mississippi Valley
  • LocationHouston, Texas
  • My C-MAX:2013
  • Current Vehicle:C-Max ENERGI

Posted 15 September 2017 - 12:54 PM

   I changed my Electronic Power Assist Steering (EPAS) system in August 2017.   The car has 78K miles on a 2013 C-Max.   I bought the car in June 2017.   I ended up doing the job myself with the help of the Helms Ford car manual.   It was doable with a transmission type floor jack to drop the subframe.   I put it all together and then had the car aligned.  

    I've had no problems so far.  The EPAS failed starting it up in the garage in the morning.   It wasn't even very hot yet for a summer day.


Edited by dlfretz, 15 September 2017 - 12:56 PM.









0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·